Start a new topic

URL from staging copy showing up in production search results

I have a staging copy of my Magento installation at http://dev.gotomedsupply.com. The production site is https://www.gotomedsupply.com. 


I have attempted to disable the module on staging, but results from the staging site keep showing up in the auto suggest on the search for the production site. 


Please advise. I'm going to have to disable the module until I'm able to get it resolved as it is sending people to the wrong site.

Hello!


It seems that the same API keys are used for the production and the staging stores. You can check them on the Searchanise settings page in the store admin panel. Each store installation using Searchanise should have unique API keys otherwise the catalog data will be mixed up.


In order to resolve the issue, it is necessary to re-install the extension in one installation to re-generate the API-keys and re-index the catalog in the other store. Please take the steps:


1. Uninstall the extension from the development store via Magento Connect.

2. Remove searchanise_config and searchanise_queue tables from your database. 

3. Then you should remove the information about these tables from the Magento resources table. Please execute the following SQL query in your database:


DELETE FROM `core_resource` WHERE `core_resource`.`code` = 'searchanise_setup'

 

4. Click the Force re-indexation button in the Searchanise control panel (Catalog > Searchanise) in admin panel of your live store.


Thank you.

Login or Signup to post a comment